3. написать программу вычисления xy, не используя функцию возведения в степень (только цикл). x,y вводятся с клавиатуры

anel1985 anel1985    3   21.06.2019 16:20    2

Ответы
anastaseyaaaa anastaseyaaaa  17.07.2020 07:25
Тривиальное решение.

var
  i,r,x,y:integer;
begin
  Write('Вычисление х в степени y, введите х,y: ');
  Readln(x,y);
  r:=x;
  for i:=2 to y do r:=r*x;
  Writeln('Результат: ',r)
end.

Тестовый прогон:
Вычисление х в степени y, введите х,y: 2 10
Результат: 1024

Вариант для любителей начинать циклы с единицы.
var
  i,r,x,y:integer;
begin
  Write('Вычисление х в степени y, введите х,y: ');
  Readln(x,y);
  r:=1;
  for i:=1 to y do r:=r*x;
  Writeln('Результат: ',r)
end.
ПОКАЗАТЬ ОТВЕТЫ
dimazhulin1609 dimazhulin1609  17.07.2020 07:25
Var x,y,p:integer;
begin
read(x,y);
p:=x;
for y:=y downto 2 do
  p*=x;
writeln(p);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика