tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
3. написать программу
3. написать программу на языке java, которая по заданному номеру единицы измерения (1 – килограмм, 2 – миллиграмм, 3 – грамм, 4 – тонна, 5 – центнер) и массы m выдавала бы соответствующее значение массы в килограммах.
0AlikaLi0
3 18.08.2019 03:10
7
Ответы
katenkaklimcuk
05.10.2020 02:04
Import java.util.*;
public class zadacha
{
public static void main(String[]args)
{
cout("Введите номер ед.изм: ");
@SuppressWarnings("resource") Scanner cin = new Scanner (System.in);
double v=cin.nextInt();
cout("Введите массу в указанной ед.изм: ");
double m=cin.nextDouble();
if (v==1) {
print(m);
}
else if (v==2) {
print(m/st(6));
}
else if (v==3) {
print(m/st(3));
}
else if (v==4) {
print(m*st(3));
}
else if (v==5) {
print(m*st(2));
}
}
public static void cout (String text)
{
System.out.print(text);
}
public static void print(double printer)
{
System.out.print(printer);
}
public static int st(int t)
{
t=(int) Math.pow(10, t); return t;
}
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
romaalykulov
22.06.2019 02:32
Сложение массива чисел условие дана последовательность целых чисел a1,…,an. вычислить их сумму. формат входного файла во входном файле содержится число n, за которым следуют...
ayazhka2
08.07.2019 14:30
Тема: обработка одномерных массивов задан массив а(10). сформировать из элементов массива а два массива в(5) и с(5), включая в первый, элементы исходного массива с четными...
Tinusya
08.07.2019 14:30
Для наблюдения используются: телескоп микроскоп лупа нужно ответ к...
vikakocherzhuk
22.10.2020 14:11
напишите 6-7 предложение и ещё не делайте сокращение например: т.к и дБ.рг я не понимаю за понимание ♥️ вот вопрос *компьютерные объекты конспект*...
mo14yn
22.10.2020 14:12
Выберите 3 правильных соответствие элементной базы поколений эвм. 1 поколение - Ламповые машины.2 поколение - Полупроводниковые машины на транзисторах3 поколение - Миникомпьютеры...
voinabeskonechnosti
07.04.2020 20:54
1. Банке 3% салымымен S теңге салынды.N жылдан кейін салым қанша болады? 2. Пурнетақтадан жұкппен 10 сан енгізіңдер. Әр жұпптағы санды салыстырып, үдкенін баспаға шығарыңдар....
sabinaaslanova
02.10.2021 02:30
Объём оперативной памяти 512 Мб, а ёмкость жёсткого диска 120 Гб. Во сколько раз ёмкость жёсткого диска больше, чем ёмкость опретатвиной памяти? ответ дать в Кбайтах)...
12233454647758886776
03.10.2019 12:01
Часть машины которая передает движение от двигателя на рабочий орган...
69supreme
03.10.2019 12:01
Решить на тему часть-целое если канал купит 4 ручки, у него останется 60 копеек, а если он купит 7 ручек, то ему не хватит 6 копеек. сколько стоит 1 ручка?...
Vanek041005
03.10.2019 12:01
She a nice dress last week (buy) сделайте из этого предложения вопрос и отрицание...
Популярные вопросы
С кем воевал Пётр в поэме? 1) с немцами 2) с англичанами 3) со шведами 4)...
1
Укажите причину Соляного бунта. 1) ограничение казачьей вольности 2) церковный...
3
Что из названного относится к причинам крестьянских восстаний XVII в.? 1)...
2
Какого цвета были мундиры у армии противника Петра?...
1
Кого, помимо «вождей своих», угощает Пётр, пируя в шатре?...
2
Какое историческое событие изобразил Пушкин в своей поэме? 1) Полтавский...
1
С каким призывом обращается Пётр к своим войскам перед боем? 1) «Вперёд,...
2
Кто из названных ниже лиц являлся первым русским землепроходцем, совершившим...
2
Прочтите отрывок из исторического источника и напишите, о ком идёт речь....
2
Как предстал перед своими войсками Карл? 1) шёл пешком 2) ехал на коне...
3
public class zadacha
{
public static void main(String[]args)
{
cout("Введите номер ед.изм: ");
@SuppressWarnings("resource") Scanner cin = new Scanner (System.in);
double v=cin.nextInt();
cout("Введите массу в указанной ед.изм: ");
double m=cin.nextDouble();
if (v==1) {
print(m);
}
else if (v==2) {
print(m/st(6));
}
else if (v==3) {
print(m/st(3));
}
else if (v==4) {
print(m*st(3));
}
else if (v==5) {
print(m*st(2));
}
}
public static void cout (String text)
{
System.out.print(text);
}
public static void print(double printer)
{
System.out.print(printer);
}
public static int st(int t)
{
t=(int) Math.pow(10, t); return t;
}
}