3.На вход программе подается натуральное число. Найдите произведение ненулевых цифр числа.Питон

Relax111111 Relax111111    2   20.04.2020 23:36    23

Ответы
KroJlick20178 KroJlick20178  13.10.2020 13:26

from functools import reduce

print(reduce(lambda x,y: x*y, [int(x) for x in input() if x != '0']))

Или менее красиво, но зато так как потом попросили:

a: int = 1

for x in input():

 a *= int(x) if x != '0' else 1

print(a)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика