§ 3.3, в тетради написать программу подсчета суммы и произведения цифр произвольного четырехзначного числа, введенного с клавиатуры.
8 КЛ​

Karapetrova05 Karapetrova05    3   16.04.2021 15:07    2

Ответы
olgamorozkina19 olgamorozkina19  16.05.2021 15:07

Программа на PascalABC.NET (Подсчёт не только 4 значного числа):

var n, sum, proizv: integer;

begin

sum := 0;

proizv := 1;

write('Введите число: ');

read(n);

while n <> 0 do begin

sum := sum + n mod 10;

proizv  := proizv * (n mod 10);

n := n div 10

end;

writeln('Сумма цифр числа: ', sum);

writeln('Произведение цифр числа: ', proizv);

end.


§ 3.3, в тетради написать программу подсчета суммы и произведения цифр произвольного четырехзначного
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика