29 . , , написать программу и блок-схему: ввести целое число и найти сумму его цифр.

Dasha12357123 Dasha12357123    3   10.08.2019 22:00    6

Ответы
Dartvaider301197 Dartvaider301197  04.10.2020 10:07
Блок-схема - в прилагаемом файле. Программа:
var n,s:integer;
begin
write('n = ');
readln(n);
n:=abs(n);s:=0;
while n>0 do begin s:=s+n mod 10;
 n:=n div 10;
 end;
writeln('s = ',s);
end.

Пример:
n = -62845
s = 25
29 . , , написать программу и блок-схему: ввести целое число и найти сумму его цифр.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика