tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
25 ! выполнять в pascalabc.!
25 ! выполнять в pascalabc.! дано x - трёхзначное число, необходимо найти 2 числа путём циклического сдвига и сумму исходного и полученных чисел.
mixmix2002
2 08.09.2019 15:10
6
Ответы
Shoxrux9818
07.10.2020 01:07
Var x,x1,x2:integer;
begin
readln(x);
x1:=(x mod 100)*10+(x div 100);
x2:=(x1 mod 100)*10+(x1 div 100);
writeln(x1,' ',x2);
writeln(x+x1+x2);
end.
Пример:
516
165 651
1332
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
666656
08.10.2019 19:28
Составьте программу, которая выполняет чертеж детали и вычисляет ее площадь. маштаб 1 клетка - 20 пикселей, 1 клетка - 1 см. радиусы отверстий и вырезок (r1,r2,r3...
Эрайз
08.10.2019 20:20
Для хранения символа 2 используется 1) пиксели 2) 1 байт 3) 1 бит 4) мегабайты...
zybi
08.10.2019 19:27
Определить количество четных чисел массива из 10 элементов. в паскале....
океекй
08.10.2019 20:20
Надо изменить эту программу так чтобы она выводила значения числа фибоначчи по введённому числу. а не до какого числа как в этой программе.var a,b,c,x: integer; beginwrite(...
kilu558028
16.05.2021 10:12
Информатика задание указанно....
kusainovy03
21.05.2019 08:54
Спо сколько льда,взятого при температуре к -5°c можно растопить полностью за 5 минут на электрической плитке,имеющей кпд 75%.напряжение в сети 220в,сила тока в плитке...
xach5
21.05.2019 10:00
Вставсе в текст слова: слова: get along, with, make a deal, were happy, called/ текст: the king all the mice together. he said: listen, boys, let s . i ll learn how...
Appolinaria06
21.05.2019 08:54
Два дня скворцы всё навещали и осматривали знакомые места выделить грамматическую основу...
Filipok220
21.05.2019 10:00
2^ -17*4^6 8^ -3 найдите значение выражения....
YuliaPyatova
21.05.2019 08:54
Веб программирование современные технологии и возможности - доклад...
Популярные вопросы
Read these sentences and fill in the gaps with the correct verb...
2
В упражнениях 4.1-4.6 по заданиям таблицям абсолихини чело или...
3
Визначте вид правопорушення. Охарактеризуйте ознаки правопорушення....
2
По двум длинным параллельным проводникам, которые содержатся на...
1
Знайти значення а та b, якщо а÷b=2÷7, а їх сума дорівнює 54...
2
Як відрізнити додатки від означень, виражених іменниками?...
2
Сколько в настоящее время насчитывается видов папоротникообразных?...
3
в промышленности этилен получают: 1)деполимиризацией полиэтилена...
1
Вычислите протяженность Африки вдоль 40 градусов в.д. В градусах;в...
2
мне дам как хотите я дам всё),но мне...
2
begin
readln(x);
x1:=(x mod 100)*10+(x div 100);
x2:=(x1 mod 100)*10+(x1 div 100);
writeln(x1,' ',x2);
writeln(x+x1+x2);
end.
Пример:
516
165 651
1332