24 1. составьте программу решения . дано трёхзначное число. вывести «да», если только его первая и третья цифры четные и «нет» в противном случае. 2. дано натуральное число. определить в нем максимальную нечетную цифру. 3. дан массив из 20 элементов, заполненный случайными числами из диапазона [-45; 55]. найти в нем сумму четных положительных элементов.

nikita2429p09umg nikita2429p09umg    1   04.10.2019 15:40    3

Ответы
Юлька1606 Юлька1606  04.10.2019 15:40

1.

var

  a: integer;

 

begin

  readln(a);

  if ((a mod 10) mod 2 = 0) and ((a mod 100) mod 2 = 0) then writeln('да')

  else writeln('нет');

end.

2.

var

  a, max: integer;

 

begin

  readln(a);

  max : = -1;

  while a < > 0 do

  begin

    if ((a mod 10) mod 2 = 0) and ((a mod 10) mod 2 > max) then max : = (a mod 10) mod 2;

    a : = a div 10;

  end;

  if max < > -1 then writeln(max)

  else writeln('');

end.

3.

var

  mas: array[0..19] of integer;

  sum, i: integer;

begin

  randomize;

  sum : = 0;

  for i : = 0 to 19 do  

  begin

    mas[i] : = -45 + random(1 + 45 + 55);

    if (mas[i] mod 2 = 0) and (mas[i] > 0) then sum += mas[i];

  end;

  writeln(sum);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика