23 ! напишите программу, которая в последовательности натуральных чисел определяет количество нечетных чисел, кратных 3. программа получает на вход натуральные числа через клавиатуру, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). количество чисел не превышает 1000. введённые числа по модулю не превышают 30 000. программа должна вывести два число: длину последовательности (завершающий 0 не учитывается) и количество нечетных чисел, кратных 3.

gnevasheva1965 gnevasheva1965    3   01.09.2019 12:20    3

Ответы
СавелийРямов СавелийРямов  06.10.2020 09:44
Progran hhh54;
var i,k,x:longint;
begin
  k:=0;
  for i:=1 to 1000 do;
    begin
      read (x);
      if (x mod 2 <> 0) and (x mod 3 = 0) then k:=k+1;
      if x=0 then begin
        break
      end;
    end;
  write (i-1,' ',k);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика