20 ! написать программу в написать программу обработки массива размерности n, которая подсчитывает кол-во элементов, которые одновременно делятся на 5 и 2. n=6

kirillmotoin kirillmotoin    1   19.09.2019 09:30    3

Ответы
serovv751 serovv751  08.10.2020 01:55
Если число k одновременно делится на числа p и q, оно также делится на их произведение p×q. Это позволяет упростить проверку и сделать программу оптимальнее.

// PascalABC.NET 3.3.5, сборка 1636 от 10.03.2018
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ReadArrInteger('Элементы массива:',ReadInteger('n='));
  Writeln('Найдено элементов ',a.Where(t->t mod 10=0).Count)
end.

Пример
n= 6
Элементы массива: -38 40 -60 35 0 18
Найдено элементов 3
ПОКАЗАТЬ ОТВЕТЫ
Анютик200511 Анютик200511  08.10.2020 01:55
Var n,i:integer;
A:array[1..6]of integer;
begin
randomize;
for i:=1 to 6 do begin A[i]:=random(100);
Write(A[i], ' ');
end;
for i:=1 to 6 do begin
if (A[i] mod 5=0)and(A[i]mod 2=0) then n:=n+1;
end;
Writeln('kolichest=',n);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика