20.2 напишите программу которая в последовательности натуральных чисел вычисляет сумму трехзначных чисел кратных 4 программа получает на вход натуральные числа количество введённых чисел неизвестно последовательность чисел заканчивается числом 0 0 признак окончания ввода не входит в последовательность количество чисел не превышает 20 введённые числа не превышают 1500. программа должна вывести одно число: сумму трехзначных чисел, кратных четырем.​

Anway2017 Anway2017    1   25.05.2019 16:56    6

Ответы
Эльза132004 Эльза132004  01.10.2020 11:32

program raf105;

var a,sum: integer;

begin

writeln('Вводите числа по очереди');

writeln('Чтобы закончить введите 0');

repeat

 if (a >= 100) and (a <= 999) and (a mod 4 = 0)

   then sum:= sum+a;

 readln(a);

until a=0;

writeln('Сумма трёхзначных чисел кратных четырём: ',sum);

end.

PascalABC 3.4.2
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика