2) заполнить массив а случайными целыми числами разных знаков. составить программу вывода на экран номеров элементов массива, равных максимальному.

мммм1984 мммм1984    2   14.08.2019 03:00    1

Ответы
Alexander0prokof Alexander0prokof  04.10.2020 17:41
Var mas: array[-1000..1000] of integer;
  i, max, n: integer;
begin
  {ввод количества элементов массива}
  readln(n);
  {ввод массива и его вывод на экран}
  randomize;
  for i := 1 to n do 
  begin
    mas[i] := 50 - random(100) - 1;
    write(mas[i]:5);
    if (i mod 10 = 0) then writeln;
  end;
  {поиск максимума}
  max := mas[1];
  for i := 2 to n do  
    if (mas[i] > max) then max := mas[i];
  {нахождение номеров элементов массива}
 writeln;
  for i:=1 to n do if (mas[i] = max) then write(i,'  ');
 end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика