2 уровень сложности
1. Написать программу, которая вводит массив из N целых чисел и выводит на экран сам массив и
среднее арифметическое элементов массива.
2. Написать программу, которая вводит массив из N целых чисел и выводит на экран сумму отрицательных элементов. Протестировать программу для следующих массивов:
а) 3 5 -2 3 -2 0 -6 -8 1
б) -1 -2 -3 -4 0 -1 2 3
3. Написать программу, которая вводит массив из N целых чисел и выводит на экран сумму положительных элементов. Протестировать программу для следующих массивов:
а) 3 5 -2 3 -2 0 -6 -8 1
б) -1 -2 -3 -4 0 -1 2 3
4. Написать программу, которая вводит массив из N целых чисел и выводит на экран произведение
нечетных элементов

Vaprosic Vaprosic    1   15.04.2020 15:23    2

Ответы
shapovalovalyubochka shapovalovalyubochka  27.04.2020 04:39

Объяснение:

var i,n:integer; a:array[1..100]of integer;

begin

write('Введите размер массива: '); readln(n);

writeln('Введите значения элементов массива, разделяя их пробелами');

for i:=1 to n do read(a[i]); readln;

for i:=1 to n do write(a[ i]:8); writeln;

for i:=n downto 1 do write(a[i]:8); writeln;

writeln('Для выхода нажмите Enter'); readln

end.

2)

var i,n:integer; a:array[1..100]of integer;

begin

write('Введите размер массива: '); readln(n);

writeln('Введите значения элементов массива, разделяя их пробелами');

for i:=1 to n do read(a[ i]); readln;

for i:=1 to n do if a[i]<0 then write(i:2,a[i]:8); writeln;

writeln('Для выхода нажмите Enter'); readln

end.

3)

var i,n:integer; a:array[1..100]of integer;

begin

write('Введите размер массива: '); readln(n);

writeln('Введите значения элементов массива, разделяя их пробелами');

for i:=1 to n do read(a[i]); readln;

for i:=1 to n do if not odd(i) then write(a[i]:8); writeln;

writeln('Для выхода нажмите Enter'); readln

end.

4)

var i,n,s:integer; a:array[1..100]of integer;

begin

write('Введите размер массива: '); readln(n);

writeln('Введите значения элементов массива, разделяя их пробелами');

for i:=1 to n do read(a[i]); readln;

for i:=1 to n do write(a[i]:8); writeln;

s:=0; for i:=1 to n do s:=s+a[i]; writeln('Sum=',s); ;

writeln('Для выхода нажмите Enter'); readln

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика