2. составьте программу, определяющую, на какую букву начинается третье слово в предложении. 3*. составьте программу, определяющую длину последнего слова в предложении. желателно в qbasic

realranktest realranktest    3   30.03.2019 06:00    7

Ответы
СамаКрутость СамаКрутость  27.05.2020 15:49

2.

Program Pr1;
uses crt;
var stroka:string;
i,a,b:integer;
Begin
clrscr;
readln(stroka);
b:=1;
if stroka[b]<>' ' then a:=1
else while stroka[b]=' ' do b:=b+1;
for i:=1 to length(stroka) do begin
if (stroka[i]=' ') and (stroka[i+1]<>' ') then a:=a+1;
if a=3 then begin
writeln(stroka[i+1]);
break;
end;
end;
end.

 

Ойтебе в QBasic...извиняй

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика