2.Напишите программу, которая в последовательности целых чисел определяет, каких чисел больше — чётных или оканчивающихся на 3 — и
насколько. Программа получает на вход целые числа, количество введённых
чисел неизвестно, последовательность чисел заканчивается числом 0 (0 —
признак окончания ввода, не входит в последовательность). Количество чисел
не превышает 1000. Введённые числа по модулю не превышают 30 000.
Программа должна вывести сообщение и одно число: каких чисел больше —
чётных или оканчивающихся на 3 — и на сколько. Если количество чисел
одинаково, то вывести это количество.
Пример работы программы:
Входные данные
182
13
12
8
5
0
Выходные данные
чётных больше на 2 числа
решить paython решите а то мне капец решите

Шмигельська Шмигельська    3   04.02.2021 17:38    8

Ответы
katerina2398 katerina2398  04.02.2021 17:40

var a,b,c:Integer;

begin

while (true) do

begin

Read(a);

if a = 0 then

break

else

if a mod 2 = 0 then

b+=1

else

if a mod 10 = 3 then

c+=1;

end;

if b<c then

WriteLn('Чисел оканчивающихся на 3 больше на '+(c-b)+' раз(а)')

else if c<b then

WriteLn('Четных чисел больше на '+(b-c)+' раз(а)')

else

WriteLn('Таких чисел нет.');

end.

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика