2. написать программу, которая вводит массив из n целых чисел и выводит на экран элементы, кратные числу k. протестировать программу на следующих исходных данных: а) k=3 массив: 2 6 -9 4 5 12 -15 б) k=4 массив: 9 0 8 124 -16 11 19 на паскале

sofa4565787 sofa4565787    3   19.06.2019 05:50    15

Ответы
Nicotenlove Nicotenlove  15.07.2020 15:29
Var 
a:array [1..100000] of integer;
i,n,k:integer;
begin
writeln('Введите n и k');
readln(n,k);
for i:=1 to n do
begin
writeln('Введите элемент №',i);
readln(a[i]);
end;
writeln('Весь массив:');
for i:=1 to n do
write(a[i],' ');
writeln();
writeln('Числа кратные ',k,':');
for i:=1 to n do
if a[i] mod k = 0 then
write(a[i],' ');
end.
ТЕСТ №1:
Весь массив:
2 6 -9 4 5 12 15 
Числа кратные 3:
6 -9 12 15 

ТЕСТ №2:
Весь массив:
9 0 8 124 -16 11 19 
Числа кратные 4:
0 8 124 -16 
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика