1вариант #1 написать программу для : вводится двухзначное число,выяснить из четных цифр оно состоит или нет решите ,дана таблица по ней все указанно,2 варианта прорешайте умоляю вас, 40

utochkins04 utochkins04    2   13.05.2019 17:50    2

Ответы
bezhkinyova bezhkinyova  10.06.2020 01:24

Так вроде, подставь цифры и всё.

Объяснение:

var

a:integer;

begin

write('введите двузначное число: ');readln(a);

writekn('ответ: ',(a div 10)+(a mod 10));

end.

ПОКАЗАТЬ ОТВЕТЫ
tat321 tat321  10.06.2020 01:24

Смотри. Я напишу тебе основную суть на Python . Если не сможешь перевести в паскаль сам, то программирование это не твое.

Объяснение:

1)

a = 62

a_1 = a / 10 # Получаем первую цифру числа. (6)

a_2 = a % 10 # Получаем вторую цифру.

if (a_2 % 2 == 0) and (a_1 % 2 == 0):

   print("Число состоит из четных цифр")

else:

print("Число состоит из нечетных цифр") #Текст заменить на нужный

2) Тут сложнее. Надо бы попробовать в реале, но мне лень.

a = 2

b = 9

for x in range(a, b) : # Это цикл от a до b на пайтоне. Суть ты понял.

    print(x)

3)

for x in range(10, 99)

   a = x

   a_1 = a / 10 # Получаем первую цифру числа.

   a_2 = a % 10 # Получаем вторую цифру.

   if (a_1 + a_2) == (a_1 * a_2):

            print(x)

Второй вариант

1)

a = 62

a_1 = a / 10 # Получаем первую цифру числа.

a_2 = a % 10 # Получаем вторую цифру.

if (a_1 + a_2) > 10:

   print("Больше")

else:

  print("Меньше")

2 задание пропущу. Ибо оч долго для меня.

3)

for x in range(10, 99)

   a = x

   a_1 = a / 10 # Получаем первую цифру числа.

   a_2 = a % 10 # Получаем вторую цифру.

   if (a_1 + a_2)  % 2 = 0 :

            print(x)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика