1cоставить программу,которая позволяет ввести строку s,затем после каждой буквы "а" вставить пробел. 2 составить программу,которая удаляет в строке s все буквы "о"

Ijorik Ijorik    2   28.05.2019 17:40    6

Ответы
lobanovartem2 lobanovartem2  26.06.2020 11:09
На всякий случай сделал проверку и на русские, и на английские.
задача 1.
uses crt;
var i:integer;
s:string;
begin
i:=1;
read(s);
repeat
if (s[i]='a') or (s[i]='а') then
s:=copy(s,1,i)+' '+copy(s,i+1,length(s));
i:=i+1;
until i=length(s)+1;
writeln(s);
end.
задача 2.
uses crt;
var i:integer;
s:string;
begin
i:=1;
read(s);
repeat
if (s[i]='о') or (s[i]='o') then
s:=copy(s,1,i-1)+' '+copy(s,i+1,length(s));
i:=i+1;
until i=length(s)+1;
writeln(s);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика