19 ! написать программу для паскаля. с клавиатуры вводятся два натуральных числа (n и m. число n меньшее). вывести на экран все числа от n до m сумма цифр которых равна 12

kirikdementev kirikdementev    1   01.09.2019 23:30    4

Ответы
ksyusa41 ksyusa41  06.10.2020 10:41
Var
   n,m,A,S:integer;
Begin
Write('n = ');ReadLn(n);
Write('m = ');ReadLn(m);
For m:= n to m do
    Begin
    S:=0;
    A:=m;
    While A > 0 do
       Begin
       S:=S+A mod 10;
       A:=A div 10
       End;
    if S = 12 then Write(m,' ')
    End;
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика