15 ! нужно составить программу в паскаль. если сумма различных целых чисел х, у, z меньше 30, то заменить меньшее из у и х суммой двух других. в противном случае увеличить все числа на 10

Bake2017 Bake2017    1   16.07.2019 21:10    6

Ответы
race201 race201  03.10.2020 05:56
Var x,y,z:integer;
begin
write('x='); readln(x);
write('y='); readln(y);
write('z='); readln(z);
if x+y+x<30
  then  if x<y then x:=x+y else y:=x+y
  else begin x:=x+10; y:=y+10; z:=z+10 end;
writeln('x=',x,'  y=',y,'  z=',z);
end.

Пример:
x=7
y=12
z=9
x=19  y=12  z=9
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика