14 составить программу в паскале нахождения периметра прямоугольника по заданным координатам его вершин аbcde

Alya23051 Alya23051    3   30.06.2019 18:40    2

Ответы
f2a5p4 f2a5p4  02.10.2020 16:26
Var
  Ax,Ay,Cx,Cy,P:real;
begin
  Writeln('Введите координаты x,y любой вершины прямоугольника: ');
  Read(Ax,Ay);
  Writeln('Введите координаты x,y диагональной вершины прямоугольника: ');
  Read(Cx,Cy);
  P:=2*(Abs(Cx-Ax)+Abs(Cy-Ay));
  Writeln('Периметр прямоугольника равен ',P)
end.

Тестовое решение:
Введите координаты x,y любой вершины прямоугольника:
2 10
Введите координаты x,y диагональной вершины прямоугольника:
-8 3
Периметр прямоугольника равен 34

14 составить программу в паскале нахождения периметра прямоугольника по заданным координатам его вер
ПОКАЗАТЬ ОТВЕТЫ
DanilVenstor DanilVenstor  02.10.2020 16:26
Var ax,ay,bx,by,cx,cy,dx,dy,p:real;
begin
write ('Введите координаты точки A: ');
read (ax,ay);
write ('Введите координаты точки B: ');
read (bx,by);
write ('Введите координаты точки C: ');
read (cx,cy);
write ('Введите координаты точки D: ');
read (dx,dy);
p:=abs(2*((by-ay)+(cx-bx)));
writeln;
writeln ('Периметр = ',p);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика