10. напишите программу: "склавиатуры вводится строка из двух слов. вывести н экран: a) первую и последнюю буквы второго слова; б) количество букв второго слова; в) количество глассных (a) в строке.все это должно быть в одной программе

pollywhite1 pollywhite1    3   13.09.2019 09:50    4

Ответы
Kirillsharko Kirillsharko  07.10.2020 11:36
Var s: string;
    n,k: integer;
begin
   write('строка: ');  readln(s);
   n:=pos(' ',s);
   if n>0 then 
   begin
     writeln('первая буква второго слова: ',s[n+1]);
     writeln('последняя буква:  ',s[length(s)]);
     writeln('количество букв:  ',length(s)-n);
     k:=0; 
     for n:=1 to length(s) do 
     if s[n]='a' then k:=k+1;
     if k>0 then writeln('количество букв a: ',k)
     else writeln('в строке нет буквы a');
   end
   else writeln('в строке одно слово');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика