10 класс составьте программу, позволяющую ввести фамилию, имя и отчество учащегося, разделенные пробелом, и вывести фамилию и инициалы. пример ввода: иванов сергей михайлович { строка s } пример вывода: иванов с. м. паскаль

Shark238 Shark238    2   30.09.2019 23:50    7

Ответы
Карнова Карнова  04.08.2020 20:33

var

str: string;

i,k: integer;

begin

write('Введите фамилию, имя и отчество: ');

readln(str);

for i:=1 to length(str) do

begin

if (str[i]<>' ')and(k=0) then

write(str[i]) else

if str[i]=' ' then

begin

inc(k);

write(' ',str[i+1],'.');

end;

end;

readln;

end.


попробуй эту программу.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика