1.Заполните массив случайными числами в интервале (0,20). Введите число X и найдете все значения, равных X. 2. Напишите программу, которая в зависимости от номера месяца выводит времена года. 3. Дан список, а=[1,2,3,4,5,8,11,13,14,16,17]. А) Удалите элемент 8; Б) добавьте в список элемент 22.

Belatrissa11 Belatrissa11    2   09.03.2022 16:30    19

Ответы
sana1998d sana1998d  09.03.2022 16:40

Python

1.

import random

X = int(input())

N_spisok = []

N = 20

for i in range(0, N):

   N_random = random.randint(0, N)

   N_spisok.append(N_random)

print(N_spisok)

for i in N_spisok:

   if i == X:

       print(i)

   else:

       break

2.

time = int(input())

zima = [12, 1, 2]

vesna = [3, 4, 5]

leto = [6, 7, 8]

osen = [9, 10, 11]

if time in zima:

   print('Зима')

elif time in vesna:

   print('Весна')

elif time in leto:

   print('Лето')

else:

   print('Осень')

3.

a = [1, 2, 3, 4, 5, 8, 11, 13, 14, 16, 17]

a.remove(8)

a.append(22)

print(a)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика