1) заполните массив случайными числами и переставьте соседние элементы, поменяв 1-ый элемент со 2-м, 3-й – с 4-м и т.д. 2) напишите программу, которая находит максимальный и минимальный из чётных положи- тельных элементов массива. если в массиве нет чётных положительных элементов, нужно вывести сообщение об этом.

moda712 moda712    3   21.09.2019 02:40    49

Ответы
alfami2004 alfami2004  08.10.2020 06:05
Var N:Array[1..20] of integer; i,j,q,k,max:integer;begin Randomize;writeln('массив');for i:=1 to 20 do beginN[i]:= random(100)-50;write(N[i]:4);end;writeln;i:=0;writeln('Измененый массив');While j<20 do beginj:= j + 2; k := N[j-1];N[j-1]:=N[j]; N[j]:= k;end;foreach q in N do beginwrite(q :4);end;end.
var N,M:Array[1..20] of integer; i,j,min,q,k,max:integer;begin Randomize;max:=-200; min:=200;writeln('1 массив');for i:=1 to 20 do beginN[i]:= random(100)-50;write(N[i]:4);if ((N[i]>0 )and(N[i] mod 2 = 0))then beginif max < N[i] then max := N[i];if min > N[i] then min := N[i];j:= j + 1;M[j]:=N[i];end;end;writeln;writeln('2 массив');foreach k in M do beginwrite(k:4);end;writeln;if (max = -200) or (min = 200)  then write ('нет чётных положительных элементов')else beginwrite('max = ' ,max:4);write('  min = ' ,min:4);end;end.
1) заполните массив случайными числами и переставьте соседние элементы, поменяв 1-ый элемент со 2-м,
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика