1)вычислить сумму четных и нечетных элементов(также в массиве). 2)вычислить количество "0" в массиве. написать программу в pascal. p.s.: можно сделать одну из двух.

Вайсбергггг Вайсбергггг    1   13.08.2019 02:30    0

Ответы
Tomoki Tomoki  04.10.2020 14:52
Program sum_nechet;
var a: array [0..100] of integer;
var b,i,c,k:integer;
begin
    randomize;
    for i:=1 to 10 do
    begin
        a[i]:=random(10);
        writeln(a[i]); // Это можно не писать, просто чтобы видеть числа в массиве, если интересно.
    end;
    c := 0;
    b := 0;
    for i:=1 to 10 do
    begin
        if a[i] mod 2 = 0 then
        b := b + a[i]
        else
        c := c+ a[i];
    end;
    writeln('Нечетных ' , c);
    writeln('Четных ' , b);
    k:=0;
    for i:=1 to 10 do
    begin
        if a[i] = 0 then
        k:= k+1
    end;
    writeln('Нулей ' , k)
end.
       
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика