1. В массиве хранятся данные о ежедневной температуре в течение августа (случайные числа от 15 до 25). Составьте программу для нахождения среднемесечной температуры. 2. Массив содержит информацию об отметках по информатике 20 учащихся класса. Отметки вводятся с клавиатуры. Составьте программу, которая вычисляет средний по предмету и количество учащихся с отметками выше среднего

nikolaivanov11 nikolaivanov11    3   20.10.2020 16:17    313

Ответы
Какашка54321 Какашка54321  20.10.2020 17:01

program xxx;

var i, m, p, n : integer;

t : array[1..31] of real;

begin

writeln('введите температуру ')

for i:=1 to 31 do

readln(t[i]);

m:=0; p:=0; n:=0;

for i:=1 to 31 do

begin

if t[i]<0 then m:=m+1;

if t[i]>0 then p:=p+1;

if t[i]=0 then n:=n+1

end;

writeln('Дней с отрицательной температурой было - ', m);

writeln('Дней с положительной температурой было - ', р);

writeln('Дней с нулевой температурой было - ', n);

readln

end.

Объяснение:

Прописка

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика