1)в free pascal составить программу нахождения суммы цифр четырехзначного числа 2) составить программу: если существует треугольник,со сторонами a,b,c , то напечатать "да",а иначе напечатать "нет"

aziret31101 aziret31101    1   16.03.2019 12:40    5

Ответы
den111111111113 den111111111113  25.05.2020 16:40

var sum, k, i: integer;


begin
readln (k);
while k > 0 do
begin
sum := sum + k mod 10; //прибавляем к сумме последнюю цифру в числе k
k := k div 10; //убираем из k эту последнюю цифру
end;
writeln(sum);
end.

 

 

 

 

 

 

var a, b, c: integer;


begin
  readln (a);
  readln (b);
  readln (c);
  if (((a + b) > c) and ((a + c) > b) and ((c + b) > a)) then //у треугольника сумма двух сторон больше третьей стороны
    writeln('да')
  else writeln ('нет');
end.

 

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика