1: составьте программу ввода с клавиатуры массива целых чисел a[1..10] и вывода на экран элементов массива с нечетными значениями. 2: составьте программу ввода с клавиатуры массива целых чисел a[1..10] и вывода на экран элементов массива с четными положительными значениями.

schastlivayolg schastlivayolg    3   25.05.2019 07:50    20

Ответы
жандос29 жандос29  01.10.2020 11:22
З1:
Program z;
var mas: array [1..10] of integer;
i, x: integer;
begin
for i:=1 to 10 do
readln(mas[i]);
for x:=1 to 10 do
if mas[x] mod 2 = 1 then writeln(mas[x]);
end.
З2:
Program z;
var mas: array [1..10] of integer;
i, x: integer;
begin
for i:=1 to 10 do
readln(mas[i]);
for x:=1 to 10 do
if (mas[x] mod 2 = 0) and (mas[x] > 0) then writeln(mas[x]);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика