1. составьте программу в pascal abc. известно, что x кг конфет стоит a рублей. определить, сколько стоит 1 кг и y кг этих же конфет. 2. составьте программу в pascal abc. дано двузначное число. найти сумму и произведение его цифр. 3. составьте программу в pascal abc. дано двузначное число. вывести число, полученное при перестановке цифр.

krivisasha4 krivisasha4    1   02.09.2019 11:30    1

Ответы
Kotofeyka5585 Kotofeyka5585  06.10.2020 12:03
1.
var a: real;
      x,y: integer;
begin
         readln(x,a,y);
         writeln('1 kg konfet stoit ', a/x:1:2);
         writeln(y,' kg konfet stoyat ', a/x*y:1:2);
         readln;
end.
2.
var a,s,p: integer;
begin
         readln(a);
         s:=a mod 10 + a div 10;
         p:=(a mod 10)*(a div 10);
         writeln(s);
         writeln(p);
         readln;
end.
3.
var a,b: integer;
begin
         readln(a);
         b:=(a mod 10)*10+(a div 10);
         writeln(b);
         readln;
end.
Это если без циклов.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика