1) составьте программу, меняющую в слове x букву "о" на букву "и", если "о" стоит на четном месте. 2)составьте программу, меняющую в слове х все сочетания "ва" на "к". заранее )

lyazkaiman0309 lyazkaiman0309    2   17.07.2019 18:30    1

Ответы
montishok montishok  21.09.2020 19:27
1.
Var 
s:string; 
i:integer;
Begin 
Write('Введите строку '); 
Readln(s); 
for i:= 1 to length(s) do   
if ((s[i]='о')or(s[i]='o'))and((i mod 2) = 0) then s[i]:='и'; 
Writeln(s); 
End.  
 
2. 
Var 
s:string; 
i,j:integer;
Begin 
Write('Введите строку '); 
Readln(s); 
s:=s+' '; 
for i:= 1 to length(s) do   
if (s[i]='в')and(s[i+1] = 'а') then Begin s[i]:='к'; for j:=(i+1) to (length(s)-1) do s[j]:=s[j+1]; end; 
Writeln(s); 
End.  
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика