1)составьте программу,которая заполняет массив e[1..11] случайными целыми числами в диапазоне от -15 до 1 и находит количество элементов кратных 5. 2)составьте программу,которая заполняет массив e[1..8] случайными целыми числами в диапазоне от 1 до 20 и находит сумму элементов с нечётными значениями и количество элементов кратных 3. 3)составьте программу,которая заполняет массив e[1..14] случайными целыми числами в диапазоне от -10 до 10,затем изменяет знак положительных элементов на противоположный,а отрицательные элементы заменяет на 0..

simalilova simalilova    1   18.06.2019 06:50    4

Ответы
fghtgxbvdrzra fghtgxbvdrzra  14.07.2020 23:23
1)
var e:array[1..11]of integer;
     i,k:integer;
begin
 for i:=1 to 11 do
  begin
   e[i]:=random(17)-15;
   write(e[i],' ');
   if e[i] mod 5=0 then k:=k+1;
  end;
 writeln;
 write('kol-vo elem krat 5:',k);
end.
2)
var e:array[1..8]of integer;
     i,s,k:integer;
begin
 for i:=1 to 8 do
  begin
   e[i]:=random(20)+1;
   write(e[i],' ');
   if e[i] mod 2=1 then s:=s+e[i];
   if e[i] mod 3=0 then k:=k+1;
  end;
 writeln;
 writeln('summa nechet elem:',s,' kol-vo elem krat trem:',k);
end.
3)
var e:array[1..14]of integer;
     i:integer;
begin
 write('nachalni massiv:');
 for i:=1 to 14 do 
  begin
   e[i]:=random(21)-10;
   write(e[i],' ');
  end;
 writeln;
 write('izmeneni massiv:');
 for i:=1 to 14 do
  begin
   if e[i]<0 then e[i]:=0
               else e[i]:=e[i]*(-1);
  write(e[i],' ');
 end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика