1.составьте программу которая заполняет массив a[1..30] случайными целыми числами в диапазоне от -15 до 30 и вычисляет произведение положительных элементов массива. 2. составьте программу которая заполняет массив a[1..40] случайными целыми числами в диапазоне от -20 до 10 и находит количество элементов массива кратным 3 3. составьте программу которая заполняет массив a[1..40] случайными целыми числами в диапазоне от -30 до 30 и находит среднее арифметическое отрицательных элементов массива

syromyatnikovа syromyatnikovа    2   11.09.2019 20:10    2

Ответы
REDbad5 REDbad5  07.10.2020 08:09
//Pascal

//1)
var
  A: array [1..30] of integer;
  i: byte; mult: double;
begin
mult := 1;
randomize;
writeln('Сгенерированный массив.');
for i := 1 to 30 do
begin
  A[i] := random(46)-15;
  if A[i] > 0 then mult := mult * A[i];
  write(A[i], ' ');
end;
writeln;
writeln('Произведение положительных элементов = ', mult);
end.
//

//2)
var
  A: array [1..40] of integer;
  i: byte; count: byte;
begin
count := 0;
randomize;
writeln('Сгенерированный массив.');
for i := 1 to 40 do
begin
  A[i] := random(31)-20;
  if A[i] mod 3 = 0 then count := count + 1;
  write(A[i], ' ');
end;
writeln;
writeln('Количество элементов кратных трем = ', count);
end.
//

//3)
var
  A: array [1..40] of integer;
  i: byte; count: byte; sum: integer;
begin
count := 0; sum := 0;
randomize;
writeln('Сгенерированный массив.');
for i := 1 to 40 do
begin
  A[i] := random(61)-30;
  if A[i] < 0 then
  begin
    count := count + 1;
    sum := sum + A[i];
  end;
  write(A[i], ' ');
end;
writeln;
writeln('Среднее арифметическое отрицательных эл. =',(sum/count):4:4);
end.
//
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика