1) составьте программу , которая заполняет массив а [1..10] случайными целыми числами в диапозоне от 1 до 10 ,затем меняет местами первый элемент со вторым,третий с четвертым и т.д. выведите на экран исходный и полученный массивы. 2)составьте программу ,которая заполняет массив а[1..10] случайными целыми числами в диапозоне от 0 до 10 , затем превый элемент меняет местами с максимальным элементом .выведите на экран исходный и полученный массив.

annamoskalenko11 annamoskalenko11    2   20.03.2019 01:50    5

Ответы
даная7234598 даная7234598  26.05.2020 06:05

1)

#include <iostream>
using std::cout;
using std::endl;
#include <cstdlib>
using std::rand;
using std::srand;
#include <ctime>
using std::time;

void print(int*);

int main()
{
   int a[10];

   srand(time(0));

   //Заполняем случайными числами от 1 до 10
   for(int i = 0; i < 10; i++)
   {
      a[i] = rand() % 10 + 1;
   }

   print(a);

   //Меняем местами
   int temp;
   for(int i = 0; i <= 10; i += 2)
   {
      temp = a[i];
      a[i] = a[i + 1];
      a[i + 1] = temp;
   }

   print(a);

   return 0;
}

void print(int *a)
{
   for(int i = 0; i < 10; i++)
   {
      cout << a[i] << ' ';
   }
   cout << endl;
}

 

 

 

 

2)

#include <iostream>
using std::cout;
using std::endl;
#include <cstdlib>
using std::rand;
using std::srand;
#include <ctime>
using std::time;

void print(int*);

int main()
{
   int a[10];

   srand(time(0));

   //Заполняем случайными числами от 0 до 10
   for(int i = 0; i < 10; i++)
   {
      a[i] = rand() % 11;
   }

   print(a);

   //Находим индекс максимального элемента
   int largest = 0;
   for(int i = 0; i < 10; i++)
   {
      if(a[largest] < a[i])
      {
         largest = i;
      }
   }

   //Меняем местами
   int temp = a[0];
   a[0] = a[largest];
   a[largest] = temp;

   print(a);

   return 0;
}

void print(int *a)
{
   for(int i = 0; i < 10; i++)
   {
      cout << a[i] << ' ';
   }
   cout << endl;
}


1) составьте программу , которая заполняет массив а [1..10] случайными целыми числами в диапозоне от
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика