1. составьте программу, которая выводит на экран таблицу перевода a, a+1, a+2, … b бит в килобайты. границы a и b вводятся с клавиатуры. протокол: введите границы: 5000 5004 5000 бит = 0.61035 кб 5001 бит = 0.61047 кб 5002 бит = 0.61060 кб 5003 бит = 0.61072 кб 5004 бит = 0.61084 кб 2. составить программу для нахождения суммы по следующей формуле: где m вводится с клавиатуры. 3. составить программу для решения следующей : ежемесячная стипендия студента составляет a рублей в месяц, а расходы на проживание превышают стипендию и составляют b рублей в месяц. рост цен ежемесячно увеличивает расходы на 3%. разработать схему алгоритма для расчёта необходимой суммы денег, которую надо единовременно попросить у родителей, чтобы можно было прожить учебный год (10 месяцев), используя только эти деньги и стипендию.

yliya302 yliya302    3   28.05.2019 17:40    17

Ответы
Melisaoz07 Melisaoz07  26.06.2020 11:17
1)
var
    a, b, i: longint;

begin
    read(a, b);
    for i := a to b do
        writeln(i:10, ' бит = ', i / 8 / 1024:10:5, ' Кб');
end.

3)
var
    a, b, s: real;
    i:integer;

begin
    read(a, b);
    for i := 1 to 10 do
    begin
        s := s + b;
        b := b * 1.03;
    end;
    writeln(s - 10 * a);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика