1.Составьте программу, которая вводит сумму и произведение натуральных чисел от 2 до 8
2.Составьте программу, которая вводит в порядке возрастания числа кратные трём в диапазоне от 3 до 20

TMTkid TMTkid    2   16.03.2020 05:20    0

Ответы
Anastasiagoodnastia Anastasiagoodnastia  11.09.2020 20:56

PASCAL если нет сам виноват

без массивов, это принцип)))

1)

program pas;

var

p, s, i: longint;

begin

p:=1;

s:=0;

for i:=2 to 8 do begin

  p:=p*i;

  s:=s+i;

  end;

write('сумма: ', s, ' произведение: ', p);

end.

2)

program pas;

var

ch, i: longint;

begin

for i:=3 to 20 do begin

  if i mod 3=0 then begin

     ch:=i;

     write(ch, ' ');

  end;

end;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика