1. Составьте программу, которая находит среднее арифметическое всех чисел от 5 до 27.


1. Составьте программу, которая находит среднее арифметическое всех чисел от 5 до 27.

Gancha163 Gancha163    1   18.01.2022 03:56    5

Ответы
Suslik1111 Suslik1111  18.01.2022 06:00

summa = 0

kolvo = 0

for i in range (5, 28):

   summa += i

   kolvo += 1

print(summa/kolvo)

Объяснение:

для начала задаём два "счётчика" - сумма и количество

для каждого числа (назовём его i) в диапазоне от 5 до 28 (28, а не 27, потому что программа считает не включительно:

к сумме добавляем это число

к количеству чисел добавляем 1

\\значок "+=" работает так: a+=1 обозначает то же самое, что и a = a+1\\

таким образом к концу этого цикла мы получим общую сумму всех чисел и их количество

программа выведет результат от деления суммы на количество

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика