1. составьте программу к : «на яблоне было х яблок. в первый день с яблони упало а яблок. каждый следующий день опадало в 2 раза больше яблок, чем в предыдущий. сколько яблок останется через k дней? ».

delvar25 delvar25    3   27.06.2019 19:30    3

Ответы
LugovoyDanila LugovoyDanila  22.07.2020 07:55
Паскаль:

var
x, k, a, i: integer;

begin
writeln('Введите количество яблок');
readln(x);
writeln('Введите количество дней');
readln(k);
writeln('Введите количество яблок, которое упало в 1 день');
readln(a);

for i:=1 to k do begin
x:=x-a;
a:=a*2;
end;

writeln(inttostr(x));
sleep(3000);

end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика