1. составьте программу для определения суммы денег, получаемой авиакомпанией от продажи билетов на рейс из лондона в нью-йорк, если в самолете три четверти пассажиров имеют билеты первого класса, стоимостью х рублей за каждый. остальные пассажиры имеют билеты второго класса, которые дешевле на 20% 2.составьте программу определения стоимости набора конфет, в которой находятся следущие сорта: наименование: количество: цена,руб: красная шапочка 500 г k алые паруса 200 г a воронежские 100 г b чародейка 250 г m

041208katy 041208katy    1   25.05.2019 22:40    3

Ответы
незнайка1187 незнайка1187  22.06.2020 06:27
Program avia;
uses crt;
var
p:integer;
s,s2,pr,ch3:real;
begin
writeln('Стоимость билета 1 класса: ');
read(s);
writeln('Общее количество пассажиров: ');
read(p);
ch3:=(3*(p/4));// 3 четверти пассажиров
pr:=(s/100)*20;// 20% от стоимости
s2:=(ch3*s)+((p/4)*pr);
writeln('Всего заработает за рейс: ',s2);
end.

program cena;
uses crt;
var
k,a,b,m,obc:real;
begin
writeln('Цена за конфеты "Красная шапочка": ');
read(k);
writeln('Цена за конфеты "Алые паруса": ');
read(a);
writeln('Цена за конфеты "Воронежские": ');
read(b);
writeln('Цена за конфеты "Чародейка": ');
read(m);

 obc:=0.5*k+0.2*a+0.1*b+0.25*m;
 writeln('Всего ',obc,' руб.')
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика