1.составьте блок-схему алгоритма и программу вывода на экран всех четных двузначных чисел. 2.составьте блок-схему алгоритма и программу вычисления суммы всех трехзначных чисел кратных 4; составьте программу вывода на экран таблицы умножения на 3 если можете алгоритм составьте

ЮлияYli ЮлияYli    3   25.06.2019 11:30    29

Ответы
вероника1062 вероника1062  20.07.2020 16:56
1.
var n,i:integer;
mass:array[1..10000] of integer;
begin
writeln('Введите кол-во чисел');
read(n);
for i:=1 to n do
begin
write('mass[',i,']=');
read(mass[i]);
end;
writeln('Элементы массива которые четные и двухначные');
for i:=1 to n do
if (mass[i] mod 2=0) and (mass[i] div 10>0) and (mass[i] div 10<10) then write(mass[i]:4);
end.
2.
var n,i:integer;
mass:array[1..10000] of integer;
begin
writeln('Введите кол-во чисел');
read(n);
for i:=1 to n do
begin
write('mass[',i,']=');
read(mass[i]);
end;
writeln('Элементы массива которые кратны 4 и трехзначные');
for i:=1 to n do
if (mass[i] mod 4=0) and (mass[i] div 100>0) and (mass[i] div 100<10) then write(mass[i]:4);
end.
3.
var i,a,m:integer;
begin
m:=3;
for i:=1 to 10 do
writeln(i,' * ',m,' = ',i*m);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика