1.составить программу вычисления суммы s=1+1/2+1/3+1/4+ | s= 1+1/2+1/3+1/4+1/n 2.вычислите значения выражения (1+2) * (1+2+3) * (1+2+3+4) * (1+2+3+) решить в pascal abc.

соня177 соня177    1   22.07.2019 09:10    7

Ответы
dfhdfhf20022004 dfhdfhf20022004  13.08.2020 20:55
1.
var i,n:integer; s:real;
begin
write('n = '); readln(n);
s:=0;
for i:=1 to n do s:=s+1/i;
writeln('s = ',s);
end.

Пример:
n = 5
s = 2.28333333333333

2.
var x,a,s:real; i:integer;
begin
write('x = '); readln(x);
a:=x; s:=x; i:=1;
while i<11 do
 begin
 i:=i+2;
 a:=x*x*a;
 s:=a/i;
 end;
writeln('s = ',s);
end.

Результат:
x = 3
s = 16104.2727272727
ПОКАЗАТЬ ОТВЕТЫ
maksfire maksfire  13.08.2020 20:55
Program n1;
var a,n:integer;
    s:real;
begin
s:=0;
write('введите число n : ');
readln(n);
for a:=1 to n do begin
s:=s+(1/a);
end;
writeln('сумма чисел от 1 до 1/',n,' = ',s);
end.
ввод :4;
вывод: 2.08333333333333;

program n2;
var s,pr:double;
    a:integer; begin
s:=1;
pr:=1;
for a:=2 to 10 do begin
s:=s+a;
pr:=pr*s;
end;
writeln('pr = ',pr);
end.
вывод: pr = 141455160000
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика