1. Составить программу ввода с клавиатуры шести чисел и нахождения суммы тех из них, которые больше 4. 2. Дан массив целых чисел А, состоящий из 7 элементов. Заполнить его с клавиатуры. Найти произведение положительных элементов массива.

Lizaveta20021 Lizaveta20021    3   04.06.2020 19:27    24

Ответы
volter16 volter16  15.10.2020 13:04
                                     PascalABC.NET                                       beginPrintln('Результат:',ReadArrInteger(6).Sum(x->x>4?x:0));Println('Результат:',ReadArrInteger(7).Product(x->x>0?x:1));end.

Первая строчка -- первое задание, вторая -- второе.

Пример работы:


1. Составить программу ввода с клавиатуры шести чисел и нахождения суммы тех из них, которые больше
ПОКАЗАТЬ ОТВЕТЫ
choika64 choika64  15.10.2020 13:04

1.

var arr: array[1..6] of integer;

var i, summ: integer;

begin

 summ:= 0;

 for i:=1 to 6 do

 begin

   readln(arr[i]);

 end;

   

 for i:=1 to 6 do

   begin

       if arr[i]>4 then

           summ := summ+arr[i];

   end;

   

 writeln(summ);

end.

var arr: array[1..7] of integer;

var i, mult: integer;

begin

 mult:= 1;

 for i:=1 to 7 do

 begin

   readln(arr[i]);

 end;

   

 for i:=1 to 7 do

   begin

       if arr[i]>0 then

           mult := mult*arr[i];

   end;

   

 writeln(mult);

end.

Краткий гайд

i - переменная-счётчикarr - массив, с которым производятся операцииsumm - (в первом задании - переменная, отвечает за сумму элементовmult - (во второй части) отвечает за произведение
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика