1.составить программу в паскале,которая предлагает ивану -царевичу выбрать правильное направление пути.у ивана-царевича есть три варианта дальнейшего пути: направо,-"коня потеряешь" налево,-"голову сложишь" вперёд,-"невесту найдёшь" 2.составить прогрмму,которая определяет положительное число или отрицательное. 3.дано целое число а.если значение а> 0,то необходимо его уыеличить на единицу.если в< 0,то уменьшить на единицу. зарание : )

VikaRayder VikaRayder    2   18.05.2019 03:20    7

Ответы
svetlanaka123 svetlanaka123  11.06.2020 08:20

program cvdcnio

uses crt;

var a:string;

begin

clrscr;

case a of

'Направо':writeln('Коняш');

'Налево': writeln('Голова');

'Вперед': writeln('Невестка');

readln

end.

 

program fcndkjn;

uses crt;

var a:integer;

begin

clrscr;

readln(a);

if a>0 then writeln(+) else writeln(-);

readln;

end.

 

program fmc;

uses crt;

var a:integer;

begin

clrscr;

readln(a);

if a>0 then writeln(a+1) else writeln(a-1);

readln;

end.  Надеюсь тут в условии, не b<0, а a<0

 

 

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика