1)составить программу, организующую массив записей о книгах, ввести информацию по следующим полям: автор, название, год издания. провести сортировку и вывести список книг, изданных после 2003 года. 2)составить программу , организующую массив записей о пяти студентах и их оценках по трем предметам. провести сортировку и вывести список отличников.

Егорик69 Егорик69    2   19.05.2019 07:20    5

Ответы
nady2111 nady2111  12.06.2020 11:46

Сделано для трёх книг, потом поменяешь в двух местах

PROGRAM prim2;
uses crt;
Type
book=record
avtor: string[20];
name:string[25];
year:integer;
end;

Var
f,i: integer;
b:array[1..3] of book;
BEGIN
clrscr;
f:=0;
{формирование записей}
for i:=1 to 3 do
Begin
write('Введите название книги: ');
readln(b[i].name);
write('Введите фамилию автора: ');
readln(b[i].avtor);
write('Введите год издания: ');
readln(b[i].year);
end;
writeln;
Writeln('Сведения о книгах (автор,название,год издания) год издания которых позже 1990');
for i:=1 to 3 do
Begin
if b[i].year>2003 then {проверка условия задачи}
Begin
f:=f+1;
Writeln(f:6,' ', b[i].avtor,' ', b[i].name,' ', b[i].year);
end;
end;
writeln('Итог: ',f);
readln;
END.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика