1)составить программу, определяющую на какую букву заканчивается предложение. 2) определить длину 2 слова в предложении

lilarthur lilarthur    3   19.08.2019 22:10    1

Ответы
vhovalyg90 vhovalyg90  24.04.2020 04:00
Var s: string;
    k: integer;
begin
  write('строка: ');  readln(s);
  writeln('строка заканчивается на букву ','"',s[length(s)],'"');
  k:=pos(' ',s);
  if k=0 then 
  begin
    writeln('в строке одно слово');
    exit;
  end;
  delete(s,1,k);
  k:=pos(' ',s);
  write('длина второго слова: ');
  if k=0 then writeln(length(s))
  else writeln(k-1);
end.

строка: это строка для проверки
строка заканчивается на букву "и"
длина второго слова: 6
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика