1. составить программу на паскале, которая выводит на экран сумму введенных с клавиатуры чисел. 2. составить программу на паскале, которая определяет является ли вводимое слово палиндромом. 3. составить программу на паскале, используя массив, которая обеспечивает ввод десяти чисел, а затем запрашивает еще одно число и выводит на экран сообщение о совпадении вводимого числа с числами в массиве 4. составить программу на паскале, которая выводит название дня недели по его номеру 5. составить программу на паскале, которая выводит вводимые числа в обратном порядке

сайнорбой сайнорбой    1   06.05.2019 21:25    3

Ответы
mrtwesor mrtwesor  09.06.2020 14:13
1.                                                        

program raf105;

var a,sum:integer;

begin

writeln('Вводите числа по очереди');

writeln('Чтобы закончить введите 0');

repeat

 readln(a);

 sum+= a;

until a=0;

writeln('Сумма: ',sum);

end.

2.                                                        

program raf105;

var

s:string;

i,k,j:integer;

poli:boolean;

begin

poli:= true;

write('Введите слово: ');

readln(s);

s:= lowercase(s);

k:= length(s) div 2;

j:= k*2+1;

if (length(s) mod 2)<>0

 then j+= 1;

for i:=1 to k do

begin

 j-=1;

 if poli

   then poli:= s[i] = s[j];

end;

if poli

 then writeln('Слово - палиндром')

 else writeln('Слово - не палиндром');

end.

 

3.                                                        

program raf105;

var a:array[1..10] of integer;

x,i:integer;

begin

writeln('Вводите 10 чисел по очереди');

for i:=1 to 10 do

 readln(a[i]);

write('Введите искомое число: ');

readln(x);

write('Индексы совпадающих элементов: ');

for i:=1 to 10 do

 if a[i] = x

   then write(i,' ');

end.

4.                                                        

program raf105;

var a:integer;

begin

write('Введите номер дня недели: ');

readln(a);

case a of

 1: writeln('Это Понедельник');

 2: writeln('Это Вторник');

 3: writeln('Это Среда');

 4: writeln('Это Четверг');

 5: writeln('Это Пятница');

 6: writeln('Это Суббота');

 7: writeln('Это Воскресенье');

end;

end.

5.                                                        

program raf105;

var a:array[1..100] of integer;

i,o,x: integer;

begin

writeln('Вводите числа по очереди');

writeln('Чтобы закончить введите 0');

repeat

 o+= 1;

 readln(a[o]);

until a[o]=0;

o-= 1;

writeln('Введённые числа в обратном порядке:');

for i:=o downto 1 do

 writeln(a[i]);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика