1.Составить программу, которая выводит сообщение о своих возможностях : Введите номер необходимой функции:
1-квадрат; 2-корень квадратный; 3-синус; 4-косинус
и считает соответствующую функцию для введённого с клавиатуры числа.

milton555 milton555    3   29.11.2020 22:26    14

Ответы
Гулзат1111 Гулзат1111  29.12.2020 22:38

#include <iostream>

#include <cmath>

#include <conio.h>

using namespace std;

int main() {

   cout << "Введите номер необходимой функции:\n1-квадрат; 2-корень квадратный; 3-синус; 4-косинус\n";

   char c;

   cin >> c;

   // Если используешь обычный компилятор (не онлайн), можно написать "char c = _getch()";

   

   cout << "Введите число: \n";

   int num;

   cin >> num;

   

   switch(c) {

       case '1':

           cout << pow(num ,2);

           break;

       case '2':

           cout << sqrt(num);

           break;

       case '3':

           cout << sin(num);

           break;

       case '4':

           cout << cos(num);

           break;

       default:

           cout << "Ошибка ввода";

   }

   return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика