1)составить программу которая выводит на экран каждое 5-ое число и таких чисел 20. 2)составить программу которая вычисляет произведение натуральных чисел от 5 до 10.

yasuper07p0ad9l yasuper07p0ad9l    3   26.05.2019 22:00    0

Ответы
Dhe32 Dhe32  23.06.2020 14:46
1.

var
i: integer;
A: array [1..20] of integer;

begin
randomize;
writeln('Массив: ');
for i:=1 to 20 do A[i]:=random(21)-10;
 for i:=1 to 20 do write(A[i]:5);
writeln;
writeln('Каждый пятый эелемент массива: ');
 for i:=1 to 20 do if i mod 5 = 0 then write(A[i]:5);
end.

2.
var
x,i: integer;
A: array [1..20] of integer;

begin
randomize;
writeln('Массив: ');
 for i:=1 to 20 do A[i]:=random(11);for i:=1 to 20 do write(A[i]:5);
writeln;
writeln('Натуральные числа в диапазоне [5..10]: ');
 for i:=5 to 10 do write(A[i]:5);
writeln;
x:=1;
writeln('Их произведение: ');
 for i:=5 to 10 do x:=A[i]*x;
write(x:5); 
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика