1. составить программу, которая вычисляет сумму и среднее арифметическое чисел вводимых с клавиатуры, пока не будет введено число 0. 2. составить программу, которая вычисляет сколько лет можно выполнять план по отлову рыбы, если запасы рыбы составляют а тонн, ежегодный прирост рыбы 25%, ежегодный план отлова с тонн. pascalabc

mam1975 mam1975    3   17.09.2019 13:30    2

Ответы
ArinaKappa ArinaKappa  07.10.2020 21:52
1)
Program n1;
var sum,k,a: integer;
begin
sum:=0;
k:=0;
readln(a);
while a<>0 do
begin
sum:=sum+a;
k:=k+1;
readln(a);
end;
write('сумма: ',sum,'; срзнач: ',sum/k);
end.
2)
Program n2;
var a,c,sum: real;
k: integer;
begin
k:=1;
readln(a,c);
sum:=a;
repeat
sum:=sum+a*0.25;
k:=k+1;
until sum>=c;
write(k);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика