1)составить программу, которая подсчитает объем любого шара по формуле: v=4/3пr^3 2)даны действительные числа x и y. необходимо определить принадлежит ли точка с координатами (x,y) окружности с радиусом r и центром в точке (x1,y1). 3)дан одномерный числовой массиф в(16). необходимо вывести на экран индексы элементов значения, которых равны числу p. cрочно надо на языке паскаль составить )

s0f21 s0f21    3   17.05.2019 21:50    2

Ответы
Mishka0512 Mishka0512  30.09.2020 19:34

Program Shar;
Var
    r, v: Real;
Begin
    
    Write('r = ');
    ReadLn(r);
    
    v := 4 / 3 * 3.14 * r * r * r;
    
    WriteLn('v = ', v);
    
    
    ReadLn;
End.

ПОКАЗАТЬ ОТВЕТЫ
kozackilya1 kozackilya1  30.09.2020 19:34

1) program ht1; 

var v,p,r:real;

begin

p:=3.14;

writeln ('vvedite r');

readln (r);

v:=4/3*p*(r*r*r);

writeln(v);

end.

 

2) program ht2;

var x,y,r:integer;
begin

writeln('vvedite r);

readln(r);
writeln('vvedite x');
readln (x);
writeln ('vvedite y');
readln (y);

if (x<=r) and (y<=r) 
then writeln ('prinadlezhit')
else writeln ('ne prinadlezhit');
end.

 

3) а в третью я врубиться не могу.

 

 

 

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика