1. составить программу для нахождения произведения чисел от 1 до 15 2. дан массив целых чисел. найти max элемент

glebik28898 glebik28898    1   09.06.2019 12:00    3

Ответы
Vladikf01Vlad220 Vladikf01Vlad220  08.07.2020 08:56
Program Prod15;

var
  p: int64;
  i: integer;

begin
  p := 1;
  for i := 2 to 15 do p := p * i;
  writeln('Произведение целых от 1 до 15 равно ', p)
end.

Тестовое решение:
Произведение целых от 1 до 15 равно 1307674368000

program emax;

const
  n = 20;

var
  i, amax: integer;
  a: array[1..n] of integer;

begin
  amax := -32768;
  writeln('Введите 20 целых чисел');
  for i := 1 to 20 do
  begin
    read(a[i]);
    if amax < a[i] then amax := a[i]
  end;
  writeln('Максимальное из чисел равно ', amax)
end.

Тестовое решение:
Введите 20 целых чисел
-5 12 0 34 26 -77 11 0 34 -23 7 0 -14 -8 34 -15 27 0 -45 23
Максимальное из чисел равно 34
ПОКАЗАТЬ ОТВЕТЫ
арсюха6 арсюха6  08.07.2020 08:56
1.

#include<iostream>
using namespace std;
int fact(int a)
{
  if(a==1) return 1;
  return fact(a-1)*a;
}
int main()
{
  cout << fact(15);
}

2.

#include<iostream>
#include<cstdlib>
#include<ctime>
using namespace std;

int main()
{
  srand(time(NULL));
  const int n = 10;
  int mass[n];
  int max;
  for(int i=0; i<n; i++)
  {
    mass[i] = rand()%100;
    cout << mass[i] << ' ';
  } 
  cout << '\n';
  max = mass[0];
  for(int i=0; i<n; i++)
    if (max < mass[i]) max = mass[i];
  cout << max;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика